VPN

De Routermage
Ir para navegação Ir para pesquisar

Para a comunicação do RouterMage com os devices, é necessário configurar uma VPN entre o servidor do RouterMage e a rede do cliente. Geralmente estabelecemos uma VPN do lado do cliente, usando o roteador de borda de rede.

A VPN utilizada é a L2TP + IPSec, e há duas formas de configurar ela:

Exemplo para MikroTik RouterOS


1. A maneira mais comum e fácil:

   ### Altere de acordo com as suas configurações!!!
   
   :global ipsecret "CHANGEME"
   :global dominio "dominio.routermage.com"
   :global vpnuser "user"
   :global vpnpass "pass"
   
   /interface l2tp-client
   
   add connect-to=$dominio allow-fast-path=no disabled=no name=routermage password=\
   $vpnpass user=$vpnuser use-ipsec=yes ipsec-secret=$ipsecret
   /


2. Quando a maneira nº 1 não funciona:

   ### Altere de acordo com as suas configurações!!!
   
   :global ipsecret "CHANGEME"
   :global localip "x.x.x.x"
   :global remoteip "x.x.x.x"
   :global dominio "dominio.routermage.com"
   :global remoteip [:resolve $dominio]
   :global vpnuser "user"
   :global vpnpass "pass"
   
   /interface l2tp-client
   
   add connect-to=$dominio allow-fast-path=no disabled=no name=routermage password=\
   $vpnpass user=$vpnuser
   
   /ip ipsec peer
   add address=$remoteip exchange-mode=main-l2tp generate-policy=port-strict \
   local-address=$localip secret=$ipsecret tunnel=yes
       
   /ip ipsec policy
   add dst-address=$remoteip dst-port=1701 protocol=udp src-address=\
   $localip src-port=1701
   /
  • A VPN precisa ter acesso à Internet, para que algumas funções funcionem de forma adequada.